Kallithea issues archive

Issue #302: [doc] On initial database creation existing repos don't get added

Reported by: Int
State: resolved
Created on: 2018-01-20 17:29
Updated on: 2018-05-06 09:11


I followed the instructions from https://kallithea.readthedocs.io/en/latest/installation_win.html

Step 9 – Configuring Kallithea

The script will ask you for the repository path, answer C:\Kallithea\Repos (or similar).

When the script is run and asks for the path of repos, it says it will import existing repos

==> This does not work. I added a hg repo to a subdirectory of C:\Kallithea\Repos but it does not get added. After setup when I log into kallithea it shows 0 repositories.



Comment by Thomas De Schampheleire, on 2018-01-20 20:02

Hello, welcome to Kallithea!

I confirm this behavior, also on Linux. In fact, I checked it on versions 0.3.3, 0.3.2, 0.3 and even went to 0.1, and this behavior is consistent in all these releases.

As there exists a separate command to rescan the repository root location, I would argue that this is not so much a bug, but rather a problem in the documentation.

In order to make Kallithea find your repositories, you have two options:

  • run the command: paster repo-scan production.ini (adapt the ini file name if needed)
  • or, via the web interface, logged in as an admin user: Admin > Settings > Remap and rescan, where you need to click the button 'Rescan repositories'.

Comment by Thomas De Schampheleire, on 2018-01-20 20:32

Comment by Thomas De Schampheleire, on 2018-01-20 21:03

In fact, this problem is solved on the default branch (but is not yet in a release). While the fact that the documentation is out-of-sync with the actual behavior in release 0.3.3 is a problem, it will rectify itself automatically on the next release off of the default branch. Therefore, I will mark this issue as resolved.

Comment by Int, on 2018-01-21 08:26

The repo-scan afterwards worked fine for me. Thank you!

Comment by Thomas De Schampheleire, on 2018-02-14 08:31

I need to clarify here: the automatic initial repository scan is dictated by the setting 'initial_repo_scan' in the ini file, which is true for the development.ini file, but not for the generated ini file using the setup script. So, even on the default branch, you need to manually scan for repositories, or set initial_repo_scan to True in the ini file. Hence, I'm reopening this bug to improve the documentation.

Comment by Thomas De Schampheleire, on 2018-02-14 08:31

documentation still needs to be improved

Comment by Mads Kiilerich, on 2018-02-15 00:48

I think initial_repo_scan should be replaced by a setup-db prompt / command line option. It is hard to imagine cases where we actually want to rescan every time a worker process is started.

Comment by Thomas De Schampheleire, on 2018-05-06 09:11

On default branch: 'setup-db' is now doing an initial repository scan, as the documentation promised.

initial_repo_scan setting in the ini file has been removed.

Thanks for creating the issue, and sorry for the delay...